GPS data missing

Answered

Comments

17 comments

  • Avatar
    Joos luteijn

    Same here. I did a route and after my ride I noticed that my GPS stopped working after about 7k, but I noticed that afterwards. During my ride everything seemed to be ok.  All other data (distance etc) is available...Strava https://www.strava.com/activities/1611330867

    0
    Comment actions Permalink
  • Avatar
    ercole

    same issue for me...

    0
    Comment actions Permalink
  • Avatar
    Steve Hammatt

    Unlikely that a new speed/distance sensor has anything to do with it, because it should still be using GPS for your position, and seems to have been doing so if your map was still tracking.

    I suggest loading up the Fit file from the activity into a utility like GPXsee, and seeing what route it draws from your data. However it sounds like it didn't record the route at all if it's not in Strava, and if that is correct then there won't be any way to retrieve it, sorry.

     

    0
    Comment actions Permalink
  • Avatar
    Bart Joosten

    Thank you for the suggestion, I tried it and as you expected it has no route information. I also checked the file on Karoo itself and it appears to be of the same size as the one on the dashboard. Maybe by accident I selected indoor as type of activity when I uploaded my ride to Strava, still strange that the data on the Karoo itself is also lacking GPS info. Will now test if my Karoo can still record GPS info. Will report back.

    0
    Comment actions Permalink
  • Avatar
    Bart Joosten

    Okay, so I recorded three short test rides, two with my city bike without sensors (to test if uploading a route to strava with checking the Trainer box would somehow erase GPS data) and one with my racer using all the sensors I used two days ago (Timex heart rate, Garmin speed/cadence 2.0), to see if the problem persists. For all three short rides GPS data was recorded and stored on the dashboard. Uploading to Strava with or without checking the Trainer box, preserves the GPS data even in Strava itself. If you check the Trainer box, the prefix 'indoor cycling' is added to you activities. After clicking on the activity and subsequently on the wrench icon, you can chose the option Export GPX, which is, obviously, not available for my ride on Sunday. 

    Could it be that even though the map was showing my position it wasn't recording my GPS, even though it was recording all my other sensor data? I didn't pay attention to a grey line being drawn or not. Could it be a potential glitch/bug? I will continue to check if the problem ever occurs again. If it does is there a way to upload some sort of report for the developers? 

    0
    Comment actions Permalink
  • Avatar
    Bart Joosten

    @Joos, weird indeed. Did you notice that your elevation data is off as well? I don't believe Utrecht is at minus 58 :) . I had to recalibrate the elevation on my Karoo as well after the update. 

    0
    Comment actions Permalink
  • Avatar
    Steve Hammatt

    Yes, you should email support@hammerhead.io and send them the Fit file and other details (including your Karoo's serial number, which they will ask for).

    0
    Comment actions Permalink
  • Avatar
    Bart Joosten

    Thank you Steve! It's always nice to get quick responses on a forum. 

    I will send them my Fit file plus serial number right away, who knows it might squash a bug.

    0
    Comment actions Permalink
  • Avatar
    Joos luteijn

    @Bart, indeed Utrecht is something like 8 meters above sealevel, So I'm safe ;-)
    I think only the GPS stopped working and all other sensors kept working. GPS data and other sensor data combined will track my ride on a map. I did not see any segment data on strava after 7km, which is calculated with all the sensor data. Strava cannot calculate without GPS data. I will sent my file to HH.

    0
    Comment actions Permalink
  • Avatar
    Bart Joosten

    Probably a redundant question, but do you see the same route trace on your dashboard's activities page? 

    Btw, I've requested a ticket here.  Hopefully this is something small. So far I am loving my Karoo.

    0
    Comment actions Permalink
  • Avatar
    Ali

    @Bart, Sorry for the delayed response here, GPS data not being recorded indeed has not been reported before we got the information from you on the ticket. This is being tested right now, thanks for your input and details.

    0
    Comment actions Permalink
  • Avatar
    Frank Assink

    i had the exact same problem on a ride yesterday.

    Map was showing correct locations but no coordinates where present in the .fit file.
    I've send the fit file to hammerhead trough the feedback portal.

    0
    Comment actions Permalink
  • Avatar
    Bart Joosten

    @Ali, no problem! Good luck with the search. Hopefully it's an easy fix. Let me know if you need more input from me or my device. 

     

    Cheers!

    0
    Comment actions Permalink
  • Avatar
    Seonghwan Jang

    I have not been able to record my GPS for a few days since I was forced to close.

    0
    Comment actions Permalink
  • Avatar
    Ali

    Hi, Seonghwan Could you please share the ride details like FIT file, route GPX and serial number with us at support@hammerhead.io?

    0
    Comment actions Permalink
  • Avatar
    Sapoferoz

    I have the same issue, started last week.

    0
    Comment actions Permalink
  • Avatar
    Ali

    @Sapoferoz- Could you please try the steps from here:Howto: Clear All Navigation Data from the Karoo before your rides?

    Also, please confirm you are available on the latest version of the software i.e. 1.5.111.3
    (Goto settings > About > build number)

    0
    Comment actions Permalink

Please sign in to leave a comment.