Known Bugs and Issues - as of March 2019

Pinned

Comments

17 comments

  • Avatar
    Russell Hodges

    As for #10, I get "GPS flakiness" immediately at the start of a ride and all the way through.  Using Golden Cheetah to look at a recent fit file contents I can see GPS drop outs starting early at the following timestamps:

    1m14s-1m24s

    1m52s-2m35s

    7m00s-8m32s

    11m15s-11m22s

    14m10s-14m17s

    14m17s-15m03s

     

    It continues like this through the whole 2 hour ride.  Let me know if you want more details.

     

  • Avatar
    Brent T

    Thank you for posting this, it really helps to see the known top priority items. Are they listed in order of priority or just a numbered list?

  • Avatar
    Ali

    They are all in a numbered list we wish to resolve as soon as possible.

  • Avatar
    Nnovod

    Great to have this list.  I was surprised to not see another attempt to upgrade the mapping software.  Perhaps that is what #6 is about.  Are these bugs also a part of #6?  Will they be addressed?

    - Rerouting fails once you go more than a little bit off-course.

    - When starting a route sometimes TBT instructions appears, sometimes they do not.

    - Creation of routes using a SIM card is very inconsistent - sometimes works, sometimes not,

  • Avatar
    Ali

    Yes, Nathaniel -all these are part of the Navigation and mapping work. The product team is validating and comparing our most viable solutions.

  • Avatar
    Nnovod

    Great to hear.  I was about to sell my Karoo, because navigation was the primary purpose I bought it and it has been unreliable on that front.  Maybe I'll stick around to see what the result of this winter's work will be.

  • Avatar
    Reginald Brown

    Hey Ali, I know that you and I discussed my issue on a ticket, but please add Powertap C1 to that list for 1. Possible that it's the same issue, or maybe it's not as bad as the issues for those, but as I discussed with you on my ticket, I do have dropouts with my C1. I've now done a ride with the Pioneer CA600, and it also never dropped connection, so both that and my Edge are rock solid with it. The CA600 will likely get returned for other reasons, but that's neither here nor there. 

    1. Stages, Power2Max, and 4iiii power meter connectivity/data issues  - (ANT+ updates have improved this but further work is to be being spent on integrating these sensors.)

  • Avatar
    Ali

    @Reginald - I understand your concerns, these list of PMs are just the widely used ones. However, the master ticket with the software team lists out all the sensors which have been reported as "Connectivity issue".

  • Avatar
    Matthew Dexter

    Does flakiness also address spontaneous reboot in cold weather? Rode to work the last couple mornings in SoCal and the temperature was in the mid 30s F. The unit rebooted once yesterday morning about 35 minutes into the ride and this morning 2x at around the same time. Stable for rest of the ride to work and the ride home. 

    Also getting routes to sync with the device is a challenge. The routes app keeps crashing. 

  • Avatar
    Niko Himanen

    I also have #10 GPS flakiness, which starts almost instantly after starting a ride. For me this seems to be somehow related to route in a ride. With route it happens, without GPS works fine. Reported to support some time ago.

  • Avatar
    Margaret Major

    Rode with a route downloaded from Strava today and GPS was a nightmare. Never had this before even using navigation. As soon as I started the ride it had an alert that there was no GPS. Then the bar would go green momentarily to say gps found then drop straight back out. Occasionally it would stick with GPS and move to 'In ride ' and navigate the route but entirely unreliable the whole ride

  • Avatar
    Victor Buriak

    Me too. Identical behavior to post above. Uploaded ok to Strava, which showed the correct results, but was really disconcerting during the ride.

  • Avatar
    Vincent Bos

    I also have #10 GPS flakiness and as a result the battery got drained. Fully charged when I started my ride and after 4 hours GPS on/off the battery was depleted. Never had this problem..started after the last update.

     

    Please prioritize this one...no point in using my Karoo if I can't ride more then 4 hours. 

  • Avatar
    David Wilcox

    The GPS glitching on my Karoo has also coincided with massive timestamp glitches in the recorded data making using that information impossible. Any update on when this will be fixed would be awesome. I can provide 2 files that show a pattern for when the timestamps are going off the rails.

  • Avatar
    Andrew King

    So I just downloaded the new update and AGAIN I'm getting the SAME error : " ERROR Tile Limit Reached; Map section storage limit reached"

    You have to be kidding me. I am NOT going to delete all of my maps again and routes and start all over. This happens EVERY time you guys push an update. I've tried the following already and it doesn't help:

    1. Enable the developer mode - How-to: Enable Developer Mode on the Karoo
    2. Tap on APPS
    3. Tap on 3dots on top right hand corner
    4. Tap on Show system
    5. Search for Offline data -> Tap on storage -> Clear data

    Any other suggestions??

    I have a new map to download and am wondering what to do?

     

  • Avatar
    Russell Hodges

    I have a Limits power meter (http://limits.technology/) which has very poor connectivity to the Karoo.  Constant drop outs and it takes many many attempts to calibrate with constant timeouts.  This is using Ant+ so it may be the same issue as number 1 above (Stages, Power2Max, and 4iiii power meter connectivity/data issues) but it has no option of bluetooth on this device.  It seems to be more reliable with my Garmin 800 so I assume this is a Karoo issue and not an issue with the device itself.

  • Avatar
    Steven Renders

    Hi, 

    Not sure if it has already been listed or reported somewhere before but recently I've noticed on the latest ATG release that sometimes when I start a route the map component will just not draw any map. It seems that it is completely unresponsive. E.g. it also doesn't react to pressing if the unlock button. You would at least expect it to changed the lock icon from locked to unlocked.

    When it happens I need to kill the ride app and start again. Sometimes multiple times.

    If it's not yet a known issue, I'll be happy to supply logs.

    Bye

    Steven

Please sign in to leave a comment.