Karoo 2 crashed / restarted itself mid ride, data lost

Completed

Comments

171 comments

  • Avatar
    Ali

    Hi MW, I have created a ticket on your behalf to work on this known issue that's under investigation.

    0
    Comment actions Permalink
  • Avatar
    Niels Frydenholm

    I experienced a similar issue yesterday (15. of april around 2pm CET, in case you have some crash logs).

    After approx 3h20min ride, the computer restarted. When it finally had rebooted, it asked if I wanted to resume the recording that was in progress when it restarted. I thought "whew, it looks like there is a feature to save this restart incident", but the resume function did not work as expected. It "resumed" my trip back to when I had been riding for 1h 2min, and also suggested I still had 179km to go (out of a 130km ride in total). 
    I stopped that "resumed ride", as it was totally messed up and it looks like that ride has totally vanished now.
    I started a new ride and recorded the last approx 1 hour ride of my ride, which went fine.

    After I had stopped the faulty resumed ride, I wanted to start the Route again, as I was in an unknown area - but my saved route was also gone from Routes (I had synced it before I started out in the morning).

    I must say, this was a really bad experience - both the crash and the non-working resume after crash function. 

    Today I have enabled developer mode to connect and see if any tmp fit file were on the device - but I couldn't find anything.

    Also, the log files I came across did not really contain any entries from yesterday, so I don't think I have any additional info I can provide to help the investigation.

    3
    Comment actions Permalink
  • Avatar
    Lee A Dorney

    And still no correction to this ;/

    0
    Comment actions Permalink
  • Avatar
    Evan Worthington

    Just happened to me today, exactly as described above. I previously had my first Karoo 2 melt on the charger, and this replacement (which I will say Hammerhead was kind enough to swap for me at no cost) has already created a corrupt file which required a reset of the OS to factory. Now this issue with two hours of ride data just disappearing. Maybe I'm on the wrong device because I don't care about the new firmware features that much, certainly not when they're going to cause what I'd consider catastrophic failure of the primary function of the device. 

    1
    Comment actions Permalink
  • Avatar
    Jiří Bačovský

    I had the same issue today. 🙁.
    If device restarts it self then at least the resume ride must work!

    1
    Comment actions Permalink
  • Avatar
    Richard

    Exact same problem struck me yesterday. About 30 minutes into a ride the screen goes black and the hammerhead logo appears. No interaction was occurring with the device at the time. 

    Upon reboot the system did not recognize that a ride had previously crashed. So I started a new ride thinking I could pull the previously created FIT file from the device. A FIT file did not exist so the first half of my ride data was permanently lost.

    1
    Comment actions Permalink
  • Avatar
    Niels Frydenholm

    I'm curious to know what version of the software you guys are on, with the restarts you have experienced the last couple of days?

    The problem is claimed to be fixed with version 1.290.1206 (https://www.eu.hammerhead.io/blogs/change-logs/karoo-software-build-version-1-290-1206) 
    From the notes:

    [KAROO 2 ONLY] We’ve fixed an issue that could cause Karoo to reboot in the middle of a ride, frequently resulting in data loss.


    But maybe it hasn't been fixed for real? :-/
    I have updated to latest version (also updated to the version above, as soon as it was released back in April), and have not experienced the issue after the update, so I'm hoping it actually is fixed, but with the new reports of the problem, I'm becoming a bit nervous that it might not be the case.

    1
    Comment actions Permalink
  • Avatar
    Richard

    I'm on 1.292.1211.12

    Strangely, I've never had the Karoo 2 crash mid-ride in the past.

    0
    Comment actions Permalink
  • Avatar
    Ali

    Hi All, I would like to keep you all updated that we found another root cause that could cause the reboot mid-ride and will be fixed in the next update, scheduled next Thursday.

    -1
    Comment actions Permalink
  • Avatar
    Evan Worthington

    I'm similarly on 1.292.1211.12 - I am nervous about trusting my Karoo 2 at this point, unfortunately I have lost some of my best rides. 

    1
    Comment actions Permalink
  • Avatar
    Jiří Bačovský

    I am on 1.292.1211.12 too. Looking forward next release. Until that I'll rather use also my watch to record my ride as backup.

    0
    Comment actions Permalink
  • Avatar
    Hashim Bishop

    Just did the hardest ride I've ever done yesterday 5/12. Planned ride was for 58 miles and 7500 ft of elevation. My Karoo 2 rebooted with 3miles left to go and lost my ride after being on the saddle for almost 6 hours! Is there anyway you guys can check your servers for my ride as I would really like to have this one back?! Please get this issue resolved and fixed as the sole purpose to having a computer is to record your activity and all the stats you've worked so hard for! Hate to see anyone else having to go through this issuue! Thanks.

    2
    Comment actions Permalink
  • Avatar
    Christian Nyström

    same thing happend to me yesterday, aftar 2hour tha karoo reboted and asked me to resume. but my recording was gone. After the reboot my data pages look different the where reseted!? but after a manually restarted the karoo they where normal again. But my activity are lost....

    I can accept that a crash and reboot happen somtimes, but the autosave/resume must work!!!

    1
    Comment actions Permalink
  • Avatar
    Niels Frydenholm

    I absolutely agree Christian - I think it's more important/urgent that they fix the autosave/resume feature than the actual bug that makes it reboot (also to be prepared the next time a bug sneaks in, that can make it reboot).

    2
    Comment actions Permalink
  • Avatar
    Lee A Dorney

    I hope mine doesn't crash today - GREAT a cycle computer that isn't reliable.. honestly 🙄

    0
    Comment actions Permalink
  • Avatar
    Jeff Martz

    Sorry Ali. This company has used up all of my patience. Your programmers are an absolute joke for releasing firmware like this. Twice weekly update this thing should be rock solid.

    Same thing happened to me today.

    The first Karoo was a bug filled joke that I was willing to tolerate because it was new.

    The second Karoo and on the first ride of the season it doesn't record half of the ride. It was a great ride, also. This really sucks. I'm stuck with yet another POS from this company.

    I don't frankly want a reply or a solution. This thing is a joke and a waste of time. I'm done spending my time trying to get a bike computer to work properly.

    The new owners should clean house and start again. These programmers, despite twice monthly updates just can't get the core functionality to work properly. If they can't make it work you need to find people who can.

    Shame on me for trusting this company would get its act together with the new product. - Never, ever again.

    2
    Comment actions Permalink
  • Avatar
    Steve MacMillan

    @ Jeff Martz Sadly Jeff, I have to agree with you. I have been using bike computers for a very long time. From the early basic ones right up to the modern 'all-singing, all dancing' ones and the Karoo2 is so unreliable as to be unusable!

    In all of the units I have used I have NEVER lost a ride because the unit had an issue. Then came the Karoo2. It cost a lot of Aussie dollars and is rubbish! The 'support' team dole out 'cut-and-paste' responses and either offer you a video call or say that 'it will be fixed in an upcoming update'. The basic function of a bike computer is to record the ride data. Whether that is a very basic distance, speed and time unit, or a unit that records a sophisticated set of metrics. The Karoo2 has failed in this most basic of tasks!

    0
    Comment actions Permalink
  • Avatar
    Lee A Dorney

    In case anyone wondering, mine didnt crash amazingly tho was expecting it too, pathetic aint it, ! 2 n a½ hr ride..

    Jeff and Steve, i empathise i rarely do! im at the end of my tether with this computer, you's are right, it should be laser tight from the off 👍

    0
    Comment actions Permalink
  • Avatar
    Stanley S

    Just happened to me, May 15, on build 1.292.1211. Mid-ride, feeling good about having hammered up a hill and curious to check the data later to see how it will compare to previous efforts — out of nowhere I'm seeing the Hammerhead logo. K2 restarts with no ride recovery/resume prompts. No partial FIT files when connected via USB. There is what looks like a fresh crash log.

    I guess I'll be recording rides with my phone.

    Ali, is there anything we can disable in the meantime that would prevent this issue? like disable Climber or phone pairing or something?

    2
    Comment actions Permalink
  • Avatar
    Lee A Dorney

    This seems like the unit is maxing out the ram and closing down then restarting to me for what i know, tho I'm no computer expert..

    0
    Comment actions Permalink
  • Avatar
    Christian Nyström

    This must be sorted out!

    Maybe everyone can write you what you did when it happened, to make is easier to Hammerhead to sort this out!?
    Maybe you have you crashlog too!?

    mine wah crashing /restart when it was autopaused... 
    i stopped att the cafe to buy a iacecream, when a come back a sew the Karoo logo on display....

    1
    Comment actions Permalink
  • Avatar
    Steve MacMillan

    Here is a paragraph from Hammerhead's website regarding the Karoo2:

    "RELIABILITY IS OUR BEDROCK

    Reliability is our bedrock principle, so that your equipment never gets in your way. Karoo also has industry’s leading customer support should you ever need it."

    Anyone care to comment? I assume the "industry’s leading customer support" probably won't.

    0
    Comment actions Permalink
  • Avatar
    Michał Kęsy

    During yesterday driving, the device restarted itself when it received a notification from the phone and detected the vehicle with radar. After self-starting, the device asked if to resume the session. After confirmation, I received the last 5 kilometers, but the device remembered the start time. I suspect that the problem may have occurred earlier because my wife wrote me a text message about my poor ride :) ( live tracking stuck at 30 kilometers ).

    0
    Comment actions Permalink
  • Avatar
    Stanley S

    Since I found a crash log on my Karoo 2, perhaps this is useful information for the developers to see. It appears to be the same issue for all of us but it is possible there are multiple scenarios that can cause this, given how they thought they fixed this previously but have now found another "root cause."

    I submitted my crash log through a support request. The steps to finding your crash logs:

    Enable Developer Mode, instructions here: https://support.hammerhead.io/hc/en-us/articles/360058885393--Karoo-2-Enabling-Developer-Options

    Access the files from your Mac or PC:

    Mac: https://support.hammerhead.io/hc/en-us/articles/360007012873-Downloading-a-FIT-file-from-Karoo-2-on-a-Mac

    PC: https://support.hammerhead.io/hc/en-us/articles/360005925374-Downloading-a-FIT-file-from-Karoo-2-on-a-PC (a note for Support on this page: the link where it says "Enable Developer Options on your Karoo 2. Click here." links to the instructions for the Karoo 1)

    But instead of the FitFiles folder look for a "crash-logs" folder.

     

    0
    Comment actions Permalink
  • Avatar
    Carlos R

    It's happened 3 times. When's the update?

    0
    Comment actions Permalink
  • Avatar
    Jeff Martz

    Not soon enough. Next Thursday.

    0
    Comment actions Permalink
  • Avatar
    Ali

    The next update is this Thursday...

    0
    Comment actions Permalink
  • Avatar
    Lee A Dorney

    Wow you're soo good Hammerhead.. 🙄

    0
    Comment actions Permalink
  • Avatar
    Christian Nyström

    Holding my thumbs that thursdays update solves this problem!

    1
    Comment actions Permalink
  • Avatar
    Dylan Kereluk

    This happened three times to me today after the new software update. This issue has absolutely not been fixed.

    Super bummed. Jacked everything up for my first Grand Fondo of the season.

    1
    Comment actions Permalink

Please sign in to leave a comment.